Tuesday, June 12, 2007

BEA-000342 - Unable to initialize the server - Problems while parsing URL file

Weblogic, zaten başlı başına yönetmesi sorun olan bir uygulama sunucusu. Ve bu sabah anlamsız bir hata ile karşılaştım... Hmm bu arada server'lara bağlanmak için SSH Secure Shell 3.2.9 kullanıyorum...

Web console'dan instance'lardan birinde işleri yönetmek için yeterince thread kalmadığını farkettim (Idle thread=0)... Ben de instance'ı restart etmeye yeltendim... Kapatırken sorun yoktu, ama açmaya çalıştığımda aşağıdaki hatayı aldım.

[13.Haz.2007 08:55:57 EEST [Emergency] [WebLogicServer] [BEA-000342] [Unable to initialize the server: weblogic.management.configuration.ConfigurationException: Exception thrown
in operation getMBeansFromURL - with nested exception:
[javax.management.ServiceNotFoundException: Problems while parsing URL file:/.../load.mlet]]


Internet'te bir kaç post okudum, ama bahsedilen case'lerin hiçbirisi sorunu mu düzeltemedi... Son olarak bir postta birisinin regional setting'ini tr'den en'e geçirdiğinde sorunu düzelttiğini yazdığını buldum... Hemen console'u açtım ve "locale" yazdım,

bash-2.05$ locale
LANG=tr_TR.ISO8859-9
LC_CTYPE="tr_TR.ISO8859-9"
LC_NUMERIC="tr_TR.ISO8859-9"
LC_TIME="tr_TR.ISO8859-9"
LC_COLLATE="tr_TR.ISO8859-9"
LC_MONETARY="tr_TR.ISO8859-9"
LC_MESSAGES="tr_TR.ISO8859-9"
LC_ALL=

yukarıdaki değerleri gördüm, hemen arkadaşıma bu makinenin restart olduktan sonra local setting'inin değiştiğini ve eski haline yani ingilizce'ye almamız gerektiğini söyledim... O da kontrol amaçlı açtı, root ile login oldu, sonra kullanıcı değiştirip "locale" yazdı, ama benim gördüğüm ekranı görmedi, tamamen doğru idi onun gördüğü (Bu arada o da SecureCRT 5.0.5) kullanıyor...

Sonra bir kaç test yaptım ve sorunun cevabını buldum... Çok basit ama anlamsız bir bug idi, benim bütün sabah bu sorun ile uğraşmamı sağlayan...

SSH Secure Shell ile bir makineye login olup ardından "su - ?" ile kullanıcı değiştirdiğinizde ilk login olduğunuz kullanıcının locale bilgileri ile diğer kullanıcıya davranıyor, yani diğer kullanıcının locale değerleri ilk login olunan kullanıcının bilgileri ile replace ediliyor, bu da beklenilenin dışında bir davranış şekli sergilenmesine sebep oluyor...

Ben sadece "locale" ile ilgili olanı buldum, kimbilir başka neler bu şekilde taşınıyor

5 comments:

oguzdag said...

Kendimi tebrik ediyorum, 3 ay sonra aynı sorunla karşılaşıp sorunu aynı şekilde blogumu okuyarak çözdüm. İşte sorunların çözüm şeklini loglamak işe yarıyor.

Metin said...

Windowsdaki sorunda da control panel -> regional settings deki
Regional options , Languages ve Advanced tablarındaki seçenekleri English (United Kingdom) yaptım.çalıştı.

Metin said...

Windowsdaki sorunda da control panel -> regional settings deki
Regional options , Languages ve Advanced tablarındaki seçenekleri English (United Kingdom) yaptım.çalıştı.

eclipse said...

Windowsta startWeblogic.cmd dosyasına aşağıdaki parametreleri ekledim çalıştı.
-Duser.language=en -Duser.region=US

ilgili link: http://www-01.ibm.com/support/docview.wss?uid=swg21237320

Anonymous said...

taşınmasını istemiyorsanız su - ile switch olmayınız. su ile switch olmanız gerekiyor.selamlar.